YesGraph SDK requires iOS SDK 9.x to compile and deployment target of iOS 8.x or later. YesGraph SDK supports both iPhone and iPad applications.

Installing with CocoaPods

The YesGraph iOS SDK is available through CocoaPods. Add the following line to your Podfile:

pod 'YesGraph-iOS-SDK'

Then run pod install command to install YesGraph SDK. When finished, add the following line to the view controller that you will call YesGraph SDK from:

import YesGraph_iOS_SDK
#import <YesGraph_iOS_SDK/YesGraphSDK.h>

Installing with Carthage

Carthage is a lightweight dependency manager for Swift and Objective-C. It leverages CocoaTouch modules and is less invasive than CocoaPods.

To install with carthage, follow the instructions on Carthage. Add the following line in your Cartfile:

github "YesGraph/ios-sdk"

Installing as a Framework

Download the latest framework from GitHub.

Drag and drop YesGraphSDK.framework file into your Xcode project. It will automatically show up in your project navigator and will be added to “Linked Frameworks and Libraries” section in project settings.

Import YesGraphSDK files as described

Note that in Swift projects, you might need to add #import <YesGraphSDK/YesGraphSDK.h> to an Objective-C Bridging Header, depending on your module settings.

Installing as a Static Library

Download the latest static library release from GitHub.

  • Drag & drop all header files into your Xcode project.
  • Drag & drop libYesGraphSDKStatic.a in your project.
  • Make sure libYesGraphSDKStatic.a is under your Build Phases section: Link Binary with Libraries
  • Open your project Target Build Settings, and for Other Linker Flags include -ObjC.

Manual Installation

You can install YesGraph manually by drag & dropping all folders in YesGraph/YesGraphSDK folder into your project. Make sure that all the files and folders are added to your target.